Problema con skype y camara web logitech quickcam pro 4000 en debian 6 squeeze

24 Febrero, 2013

Durante estos días e instalado skype 4.0 en mi sistema debian 6 squeeze por necesidad, en una computadora ya un poco vieja una HP 530, por lo que dicha computadora no viene con cámara integrada asi que me toco buscar la cámara web que tenia guardada una logitech quickcam pro 4000, pero al conectarme a skype no lograba hacer funcionar el vídeo, aunque el micrófono si funcionaba.

Asi que de nuevo me puse en la búsqueda de una solución y encontré una solución que me funciono, la cual fue entrar a la consola como superuser (super usuario) y colocar (con la cámara conectada, aunque no se si importa o no)

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype (debes tener instalado libv4l en tu sistema debian, si no lo tienes el comando para instarlo es el siguiente apt-get install ibv4l-0)

una vez dado enter skype fue lanzado por el mismo comando dado que tiene el skype al final, pero segui teniendo problemas (no se veía el vídeo  solo una pantalla negra) por lo que decidí reiniciar la pc, una vez de nuevo en el sistema operativo debian, lance skype y esta vez el vídeo de mi cámara web logitech quickcam pro 4000 si funcionaba, por lo tanto problema solucionado (en casi todo cuando hablo por skype mi vídeo se mezcla en algunas ocasiones con el vídeo de la personas con la que hablo, aunque solo se manifesta en de mi lado, y no del lado de la persona con la que hablo)

Al parecer esta solucion puede ser aplicada para camaras web viejas.

Otra solucion (entre muchas encontradas) es que dicen de cambiar simplemente la cámara de puerto USB o colocar la camara en un puerto USB que no comporta con otro dispositivo, aunque dicha solución no me funcionan

  • jose

    no es mui bien